EIGRP --- 增强内部网关路由协议

0x00 EIGRP简介

EIGRP(Enhanced Interior Gateway Routing Protocol)增强内部网关路由协议,也是Cisco公司的私有协议(当Cisco设备和其他厂商的设备互连时,不能使用EIGRP协议),它结合了链路状态和距离矢量型路由选择协议的Cisco专用协议,具有快速收敛,减少带宽占用等特点。EIGRP是Cisco的私有路由协议,它综合了距离矢量和链路状态2者的优点,它的特点包括:1.快速收敛EIGRP采用DUAL来实现快速收敛。运行EIGRP的路由器存储了邻居的路由表,因此能够快速适应网络中的变化。如果本地路由表中没用合适的路由且拓扑表中没用合适的备用路由,EIGRP将查询邻居以发现替代路由。查询将不断传播,直到找到替代路由或确定不存在替代路由2.部分更新EIGRP发送部分更新而不是定期更新,且仅在路由路径或者度量值发生变化时才发送。更新中只包含已变化的链路的信息,而不是整个路由表,可以减少带宽的占用。此外,还自动限制这些部分更新的传播,只将其传递给需要的路由表,因此EIGRP消耗的带宽比IGRP少很多。这种行为也不同于链路状态路由协议,后者将更新发送给区域内的所有路由器。3.支持多种网络层协议EIGRP使用协议无关模块来支持IPv4、IPv6、Apple Talk和IPX,以满足特定网络层需求。4.使用多播和单播EIGRP在路由器之间通信时使用多播和单播而不是广播,因此终端站不受路由更新和查询的影响。EIGRP使用的多播地址是224.0.0.105.支持变长子网掩码(VLSM)EIGRP是一种无类路由协议,它将通告每个目标网络的子网掩码,支持不连续子网和VLSM6.无缝连接数据链路层协议和拓扑结构EIGRP不要求对OSI参考模型的2层协议做特别的配置.不像OSPF,OSPF对不同的2层协议要做不同配置,比如以太网和帧中继,EIGRP能够有效的工作在LAN和WAN中,而且EIGRP保证网络及不会产生环路(loop-free);而且配置起来很简单;支持VLSM;它使用组播和单播,不使用广播,这样做节约了带宽;它使用和IGRP一样的度量值算法,但是EIGRP度量值是32位的;它可以做非等价的路径的负载平衡

0x01 EIGRP配置

网络拓扑如下

拓扑图.png

端口地址分配如下

地址表.png

按照表格地址配置好各个端口的IP地址配置EIGRP协议在R1上做以下配置

R1(config)#router eigrp 1

R1(config-router)#network 70.70.0.0

R1(config-router)#network 90.90.1.0


在R2上做以下配置

R2(config)#router eigrp 1

R2(config-router)#network 70.70.1.0

R2(config-router)#network 80.80.1.0

R2(config-router)#network 10.10.1.0


在R3上做以下配置

R3(config)#router eigrp 1

R3(config-router)#network 80.80.1.0

R3(config-router)#network 90.90.1.0

R3(config-router)#network 80.80.3.0


查看各个路由器的路由表

R1路由器的路由表

R1路由表.png


R2路由器的路由表

R2路由表.png


R3路由器的路由表爱

R3路由表.png

0x02 其他命令


show ip protocols        //显示活跃路由选择协议进程的参数和当前状态show ip protocols.png


show ip eigrp topology     //显示EIGRP的拓扑表的后继路由器和可行后继路由器show ip eigrp topology.png


show ip eigrp neighbors   //显示邻居表的IP地址和holdtime等信息show ip eigrp neighbors.png


show ip eigrp interfaces   //显示EIGRP端口信息,观察邻居数show ip eigrp interfaces.png


0x03 补充

EIGRP 手动总结要在发送 EIGRP 数据包的所有接口上建立 EIGRP 手动总结,请使用下列接口命令:

Router(config-if)#ip summary-address eigrp as-number network-address subnet-mask

EIGRP 需要使用 redistribute static 命令才能将此静态默认路由包括在其 EIGRP 路由更新中。

标签: none

添加新评论